linuxBean14.04(154)Eclipseのプラグインが全くインストールできなくなる

ラベル: ,
linuxBean14.04(133)Eclipse4.6(Neon)とPyDev5.4のインストールでインストールしたEclipse IDE for JavaScript and Web Developersのプラグインが何もインストールできないことに気が付きました。結局解決できず原因もわかりませんでした。

前の関連記事:linuxBean14.04(153)BashEclipseをEclipse 4.6 Neon.2にインストールする


リポジトリが読めないといわれてプラグインがインストールできない


家で使っているVirtualBoxのlinuxBean14.04のEclipse4.6.2にもBashEclipseをインストールしようとするとリポジトリに一切アクセスできません。

Help→Install New Software。


Work withのリストからどのリポジトリを選択してもエラーがでてなにもインストールできません。


「Unable to read repository at http://download.eclipse.org/releases/neon. 許可がありません。」と言われています。

ローカルディスクのzipファイルにあるリポジトリにもアクセスできないのでネットワークの問題ではありません。

Unable to read repository at http://download.eclipse.org/releases/indigo - Stack Overflow

この上位二つの回答の方法をやってみましたがいずれも解決できませんでした。

linuxBean14.04の「ソフトウェアの更新」をしても解決しません。

PyDevをインストールしたときにはリポジトリにアクセスできているので、いつのまにかリポジトリにアクセスできなくなったということです。

linuxBean14.04(137)Eclipse4.6からファイルマネージャを開く設定

仮想マシンでこの状態まで戻ってみましたが結果は同じでどのリポジトリにもアクセスできません。


このときStartExplorerのプラグインのインストールに失敗しています。

その次にやったExploreFSプラグインではダウンロードすらできなかったと書いています。

ということはこのあたりでアクセスできなくなったということです。

あとで振り返るとlinuxBean14.04(134)Eclipse4.6とLibreOffice5.2のPythonマクロのときに同じように「許可がありません」と言われているのでこのときからおかしかったようです。

VirtualBoxのゲストOSなので書き込みに失敗してファイルが壊れてしまったのだろうと思います。

Eclipse Java EE IDE for Web Developers. をインストール


どうしようもないのでEclipse Java EE IDE for Web Developers. Version: Neon.2 Release (4.6.2)を新たにインストールしました。

これでは問題なくリポジトリにアクセスできたので、ネットワークとかOSが原因ではありません。

しかもこのEclipseには以前失敗したhttp://www.junginger.biz/eclipse/からExploreFSのインストールができました。

ファイルマネージャが見つけられないといわれて期待通りには動作しませんが。

linuxBean14.04(137)Eclipse4.6からファイルマネージャを開く設定のときにインストールできなかったのはリポジトリ側の問題ではなかったようです。

http://basti1302.github.com/startexplorer/update/のStartExplorerもインストールできました。

しかもプロジェクトを右クリック→StartExplorer→Show in File Managerでファイルマネージャでプロジェクトフォルダを開くことができました。

ということでこれらのプラグインのインストールが原因でリポジトリにアクセスできなくなったのではなくて、その前からおかしくなっていたということがわかりました。

Eclipseのパッケージの違いかと思って、Eclipse IDE for JavaScript and Web Developersのダウンロードしたtar.gzファイルがまだディスクに残っていたので再インストールしてみました。

これも問題ありませんね。

ということは使っている間におかしくなったわけですが、結局原因ははっきりわからず、解決法はEclipseの再インストールとなりました。

workspaceは問題ないようでそのまま使えました。

参考にしたサイト


Unable to read repository at http://download.eclipse.org/releases/indigo - Stack Overflow
このQ&Aを読んでも解決せず、Eclipseの再インストールで解決しました。

次の関連記事:linuxBean14.04(155)EclipseのStartEcplorerプラグインのインストール

PR

0 件のコメント:

コメントを投稿